USSUP-636 Support phone line unavailable (214) 272-2086

Incident Report for 2sms LLC

Resolved

This incident has been resolved and the affected phone line is functioning again.
Posted Mar 10, 2025 - 15:04 UTC

Investigating

Currently one of our support phone lines (214) 272-2086 is unavailable.

We’re working with our supplier to resolve the issue.

Users may call (877) 276-7266 instead or email support@2sms.us if not urgent.
Posted Mar 06, 2025 - 17:16 UTC
This incident affected: Support Services.