Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 06, 2025 - 06:00 UTC
Scheduled
We are writing to inform you that our phone supplier will be conducting essential maintenance task on our support phone lines.
Type: Scheduled Essential Maintenance
Impact: - No impact to SMS traffic. - Unlikely impact to support phone lines may occur.
We appreciate your patience and apologize for any inconvenience during this maintenance period.
If for any reason the maintenance is extended or cancelled we will advise you accordingly. Please contact support@2sms.us should you require further information or assistance.
Posted Feb 28, 2025 - 11:35 UTC
This scheduled maintenance affected: Support Services.