Primary Support Phone Number Unavailable
Incident Report for 2sms LLC
Resolved
The primary support phone number disruption is resolved.

We have had confirmation of restoration work from our supplier's upstream carrier.

We have requested further information on the cause.
Posted Jul 20, 2023 - 08:46 UTC
Investigating
We’re currently experiencing a service disruption with our primary support phone number (877) 276 7266.

Our team is working with our telephone provider to identify the root cause and implement a solution.

We can be reached at the alternative phone number (214) 272-2086 or by email support@2sms.us
Posted Jul 13, 2023 - 15:41 UTC
This incident affected: Support Services.