USSUP-245 Support telephone lines are unavailable
Incident Report for 2sms LLC
Postmortem

Description:

Inbound calls to the support telephone lines were receiving a busy signal.

Impacted Services:

  1. Inbound Support Telephone Service

Impacted Customers:

  1. All customers

Cause:

Calls were not reaching the 2sms Teams based call system. Our supplier has provided us with the information that numbers were not hitting our suppliers network, this was due to an upstream routing error.

Detection:

A customer reported to use through alternative channels that they were receiving a busy signal when attempting to contact 2sms via telephone.

Corrective Actions:

2sms investigated the reported telephone disrupted service and once it was deemed external of 2sms, the issue was escalated with our telephone supplier. Our supplier found that the telephone calls were not being received to their system, and they escalated to the upstream carrier. The carrier found that the cause was a routing issue which was corrected. Calls then flowed once again.

Preventative actions:

Our suppliers are reviewing with the carrier why the routing error occurred. We are looking to implement a backup telephone line with an alternative supplier to provide continuity of service.

Posted Nov 18, 2022 - 17:13 UTC

Resolved
The support phone line disruption has been resolved by our supplier.

We’re sorry for the inconvenienced caused.

We will be seeking an RCA from our supplier to understand this issue further.
Posted Nov 17, 2022 - 13:46 UTC
Monitoring
Our supplier has restored inbound telephone services.

Customers should now be able to reach us by phone once again.

We're monitoring to ensure the phone lines remain stable and operational.
Posted Nov 17, 2022 - 13:25 UTC
Update
We’re continuing to experience disruption with our support phone lines.

Our supplier is continuing to work to identify the root cause and implement a solution.

Customers wanting to contact support can do so by emailing support-us@2sms.us
Posted Nov 16, 2022 - 15:29 UTC
Update
We have escalated this issue to our phone line provider and they are investigating as a high priority, we will advise when we have further information.
Posted Nov 16, 2022 - 10:52 UTC
Investigating
Our telephone lines are currently unavailable, if you need to contact us please email support-us@2sms.us
Posted Nov 16, 2022 - 10:51 UTC
This incident affected: Support Services.